Here are some FAQs and solutions for your ISUP pump. 


My gauge is not registering.

This gauge reads the pressure inside the board after about 7-8 PSI, which does take some time (around 10 minutes). It actually will not move until it hits at least 7-9 PSI. You may think the board is full, but if the gauge does not move, the board is not full enough. 

You can quickly check your gauge by removing the hose from the pump. Place you hand over the opening where the hose attached, create a good seal to ensure no air escapes and compress the pump handle. The gauge reads at a high pressure so don't be afraid to push hard! You will see the gauge start to register when you push hard. Here is a link with additional helpful tips:


http://help.vilanobikes.com/support/solutions/articles/6000162131-my-gauge-won-t-register-is-it-broken


My board is leaking when I pump.

When the pump is attached to the board the valve is open and if you stop pumping with less intensity or stop altogether the air will start to come out. Our suggestion to counteract that is to disconnect the pump hose have a rest and start again.


The board is difficult to pump and it takes two people. One to hold the hose in place and the other to pump. 

If you are having this experience all you will need to do is swap the o-ring on the end of your hose. In your package was included a spare o-ring that will be a little thicker than the o-ring included on the hose, all you will need to do is swap them out. This will create a tighter seal for and allow you to pump the board by yourself. 


I can not get the hose to stay in the valve.

The hose will take a good amount of down pressure and twisting motion to screw into position. You will need to ensure the seal is tight so that no air can leave. You feel a faint ‘click’ once it sits in place.